Oracle 10G DB Install Issues on OEL 4 Linux x86_64

Apr 4, 2008 / By Balraj Chahal

Tags:

I recently installed Oracle DB 10.2.0.1 RAC (two nodes) on Oracle Enterprise Linux x86_64 and faced three issues. Since I had to dig out at several places, I thought it might benefit others to have my notes all here.

Facts

  1. OS : OEL 4 — 2.6.9-67.0.0.0.1.ELsmp #1 SMP Sun
  2. 2 Node RAC Install
  3. Clusterware / RDBMS – 10.2.0.1

Issue 1: Error while loading shared libraries: libstdc++.so.5 during root.sh run on first node.

root@linux1 oracle]# /u02/app/oracle/product/crs/root.sh
WARNING: directory '/u02/app/oracle/product' is not owned by root
WARNING: directory '/u02/app/oracle' is not owned by root
Checking to see if Oracle CRS stack is already configured

Setting the permissions on OCR backup directory
Setting up NS directories
Oracle Cluster Registry configuration upgraded successfully
WARNING: directory '/u02/app/oracle/product' is not owned by root
WARNING: directory '/u02/app/oracle' is not owned by root
/u02/app/oracle/product/crs/bin/crsctl.bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or
directory
Failure initializing entries in /etc/oracle/scls_scr/linux1.
[root@liux1 oracle]# chown -R root:dba /u02/app/oracle/
chown: cannot dereference `/u02/app/oracle/product/crs/lib32/libagtsh.so': No such file or
directory

On Node 2:

[root@linux2  VOTINGDISK]# /u02/app/oracle/product/crs/root.sh
WARNING: directory '/u02/app/oracle/product' is not owned by root
WARNING: directory '/u02/app/oracle' is not owned by root
Checking to see if Oracle CRS stack is already configured

Setting the permissions on OCR backup directory
Setting up NS directories
Failed to upgrade Oracle Cluster Registry configuration

ldd /u02/app/oracle/product/crs/bin/crsctl.bin
libclntsh.so.10.1 => not found
libhasgen10.so => not found
libocr10.so => not found
libocrb10.so => not found
libocrutl10.so => not found
libskgxn2.so => not found
libdl.so.2 => /lib64/libdl.so.2 (0x0000003c58900000)
libm.so.6 => /lib64/tls/libm.so.6 (0x0000003028900000)
libpthread.so.0 => /lib64/tls/libpthread.so.0 (0x0000003c59100000)
libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003c60400000)
libstdc++.so.5 => /usr/lib64/libstdc++.so.5 (0x0000002a95577000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003c5b700000)
libcxaguard.so.5 => not found
libc.so.6 => /lib64/tls/libc.so.6 (0x0000003c58600000)
/lib64/ld-linux-x86-64.so.2 (0x0000003c58400000)

Ref: Metalink Note 400565.1 / Bug.5671963. Install compat-libstdc++-33-3.2.3-47.3.ia64.rpm and repeat the Oracle Clusterware installation.

Issue 2: PRKN-1008: Unable to load the shared library srvmhas10 during root.sh run on first node:

NO KEYS WERE WRITTEN. Supply -force parameter to override.
-force is destructive and will destroy any previous cluster
configuration.
Oracle Cluster Registry for cluster has already been initialized
Startup will be queued to init within 90 seconds.
Adding daemons to inittab
Expecting the CRS daemons to be up within 600 seconds.
CSS is active on these nodes.
linux1
linux2
CSS is active on all nodes.
Waiting for the Oracle CRSD and EVMD to start
Oracle CRS stack installed and running under init(1M)
Running vipca(silent) for configuring nodeapps
PRKH-1010 : Unable to communicate with CRS services.
[PRKH-1000 : Unable to load the SRVM HAS shared library
[PRKN-1008 : Unable to load the shared library "srvmhas10"
or a dependent library, from
LD_LIBRARY_PATH="/u02/app/oracle/product/crs/jdk/jre/lib/i386/client:/u02/app/or
acle/product/crs/jdk/jre/lib/i386:/u02/app/oracle/product/crs/jdk/jr
e/../lib/i386:/u02/app/oracle/product/crs/lib32:/u02/app/oracle/product/crs/srvm
/lib32:/u02/app/oracle/product/crs/lib:/u02/app/oracle/product/crs/srv
m/lib:/u02/app/oracle/product/crs/lib"

]] PRKH-1010 : Unable to communicate with CRS services. [PRKH-1000 : Unable to load the SRVM HAS shared library [PRKN-1008 : Unable to load the shared library "srvmhas10" or a dependent library, from LD_LIBRARY_PATH="/u02/app/oracle/product/crs/jdk/jre/lib/i386/client:/u02/app/or acle/product/crs/jdk/jre/lib/i386:/u02/app/oracle/product/crs/jdk/jr e/../lib/i386:/u02/app/oracle/product/crs/lib32:/u02/app/oracle/product/crs/srvm /lib32:/u02/app/oracle/product/crs/lib:/u02/app/oracle/product/crs/srv m/lib:/u02/app/oracle/product/crs/lib"

]] PRKH-1010 : Unable to communicate with CRS services. [PRKH-1000 : Unable to load the SRVM HAS shared library [PRKN-1008 : Unable to load the shared library "srvmhas10" or a dependent library, from LD_LIBRARY_PATH="/u02/app/oracle/product/crs/jdk/jre/lib/i386/client:/u02/app/or acle/product/crs/jdk/jre/lib/i386:/u02/app/oracle/product/crs/jdk/jr e/../lib/i386:/u02/app/oracle/product/crs/lib32:/u02/app/oracle/product/crs/srvm /lib32:/u02/app/oracle/product/crs/lib:/u02/app/oracle/product/crs/srv m/lib:/u02/app/oracle/product/crs/lib"

]]

Ref: Metalink Note 342750.1. Make sure that rpm glibc-2*.i686.rpm and glibc-devel-2*.i386.rpm are installed.

Issue 3: DB Startup fails on second node

$ sqlplus "/ as sysdba"
SQL*Plus: Release 10.2.0.2.0 - Production on Mon Oct 2 17:12:40 2006
Copyright (c) 1982, 2005, Oracle. All Rights Reserved.
oraclexxxx: error while loading shared libraries: libaio.so.1: cannot open
shared object file: No such file or directory
ERROR:
ORA-12547: TNS:lost contact

Ref: Metalink Note 394297.1: Install libaio-0.3.105-2.X86_64.RPM (a higher version will also work).

After having the above RPMs in place on the second node, the database was created on both nodes without problem.

Leave a Reply

  • (will not be published)

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>