First Look at Kubuntu 9.10, “Karmic Koala”

Oct 9, 2009 / By Brad Hudson

Tags: ,

I just installed a copy of the titular distro last night and have been playing with it a bit. So far it’s been less trouble than I would have expected from a first beta, and runs well. Get Kubuntu 9.10 Karmic Koala beta 1 here. A word to the wise, this is beta software and not yet ready for prime time.

I installed it on my laptop, I use it for a lot of things but the data is always expendable. I had installed it in a VM a few days previously but that was not as satisfying as trying it in the real world as opposed to the idealized world of the VM.

Test Specs

  • Compaq EVO n610c
  • Mobile Intel(R) Pentium(R) 4 – M CPU 2.40GHz
  • TEAC DW-224E-A 24x/24x writer cd/rw
  • Fujitsu MHT2040A 5400RPM drive
  • 512MB DDR
  • D-Link DWL-G630 802.11g Atheros AR2413
  • ATI Radeon Mobility M7 LW [Radeon Mobility 7500]

The Install

From the get-go there was trouble. The install CD would not boot past the initial menu where I had selected the install option. It just stopped and presented no error messages. I tried the alternate CD with the same result. Thanks to the alternate CD I was able to boot with the ‘noapic’ options which fixed the issue.

Install after that went smoothly. The install has been slick for the last several releases, and this one is no different. The partition tool has been updated and now support creating LVM and software raid in the menu (It may have been there in previous versions, but I never noticed it). I decided to use ext4, which is the default now, as I had not trusted it in 9.04 and wanted to give it a spin. I also said yes to using ecryptfs for my home directory (more on that in another post).

The alternate CD is a sloooow way to install. It’s all text based but seems to take much longer when the file copies are going. Maybe I was too excited and impatient. A new distro is always a bit like Christmas morning.

Desktop Problems

The first boot happened as planned. It seemed to be a fast boot but this laptop is not the best test for speed. I logged in and bam!, I hit my first roadblock. My desktop came up fine, but my panel was not rendered correctly. Not only that, the menu came up unreadable and the window dressings on each of my windows was similarly garbled.

I tried to connect to my wireless, but with network-manager running configuring it using command line tools was not working. I hooked up a wire and updated the system. After an ‘apt-get update’ followed by an ‘apt-get upgrade’ installed a massive 302MB of updates. Some were held back, so I also had to do an ‘apt-get dist-upgrade’ to get another 52MB of updates. This did not fix my display problem as I had hoped.

I did some digging through /var/log/Xorg.0.log and everything looked right, it was correctly detecting my video card and using the open source ati driver (this poor sad little card is not supported by fglrx). Playing with the KDE system settings did not yield any results. I was able to get a working desktop using the vesa driver, but that was not satisfying.

The fix was to force xorg to use a different acceleration method. Here’s how you do it. Create a custom xorg.conf file. Kubuntu 9.10 uses xorg 1.6.3 which does not need a config file by default. The xorg.conf can be used to override some settings.

Edit the file using sudo, as the /etc/X11 is owned by root.

sudo vi /etc/X11/xorg.conf

Add this into the file.

Section "Device"
        Identifier      "vga"
        Driver          "ati"
        Option          "AccelMethod"   "EXA"
EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device          "vga"
        Monitor         "Configured Monitor"
EndSection

Log out and restart your X server, or reboot if you prefer.

The key here is the option specifying the AccelMethod as EXA. For some reason xorg was trying to use XAA by default, which is an older method which was replaced by EXA in 2005. Doing the above tells xorg to use EXA by default instead. Once this was done I had a nicely working desktop.

The desktop runs faster than I expected in the low power, low memory conditions. I have managed to set up most of my apps to my liking and got the essentials installed.

Essential Apps

While on the subject, here are a few of my immediate installs after a build. All apps below are referenced by package name, so just do an sudo apt-get install [packagename] to install them.

  • vim-full – ubuntu comes installed with an annoyingly pared down version of vim. Get this one to do stuff like navigating with arrow keys while in insert mode. If you know what I mean, then this is for you.
  • vpnc – A vpn client for linux which is great for connecting to Cisco VPNs.
  • Firefox – I have no idea why this is not installed by default, likely to do with licensing. The K->Applications->Internet menu has an item called “Firefox Installer”, which does not seem to work.
  • mplayer – The most incredibly awesome movie player for linux.
  • pidgin – Multiprotocol chat client. kubuntu installs kopete as the default, but I always prefer pidgin.
  • konversation – A great little IRC program for KDE. While Pidgin does IRC I find the old ways are best for IRC.
  • pan – The only news reader for Linux you’ll ever need.
  • Thunderbird – Another that should be installed by default, but a great mail client. Kontact/KMail is very good too and is included by default.
  • Gimp – The Gimp. Not quite Photoshop still, but excellent in its own right.
  • build-essential – This is a meta package, meaning that it installs a bunch of other packages. These are what you need if you ever want to compile anything. A must have if you compile from source like I do quite often.

I’ll post more as I have more time to play with Karmic. If I find anything of interest, I’ll let you know.

10 Responses to “First Look at Kubuntu 9.10, “Karmic Koala””

  • Bill Fraser says:

    Hi Brad,

    Nice article. I just wanted to point out that the reason you noticed support for LVM and software RAID is they are specific to the alternate CD. From the download page for the release (http://releases.ubuntu.com/releases/9.10/), the alternate install provides for the following situations:

    - setting up automated deployments
    - upgrading from older installations with no network access
    - LVM and/or RAID partitioning
    - installs on systems with less than ~256MB of RAM

  • Brad Hudson says:

    That would explain it. Thanks Bill!

  • [...] Ubuntu 9.10 beta 1 released for both Gnome and KDE desktops. The newest version of Ubuntu, code named “Karmic Koala”, is coming out in 20 days, but the first beta release was released this week. The adventurous can download the install images from the Ubuntu site (or Kubuntu if you prefer). Your editor reports on his first look at installing and running the newest version. [...]

  • Dixie Raj says:

    Excellent…. The Evo display issue resolution is just amazing… You made my day.

  • mark says:

    anyone tried this fix above?

    i implemented the fix and it choked:

    parse error on line 14 of section Screen in file /etc/X11/xorg.conf

    unexpected EOF. Missing EndSection keyword?

    (ee)problem parsing the config file

    fatal server error
    no screens found

  • Lukas says:

    I got a weird issue with cisco vpn client on this Kubuntu release, I spent whole day on it today but couldn’t fix it.

    I used vpnclient-linux-x86_64-4.8.02.0030-k9.tar.gz, it compiled fine after patch vpnclient-linux-2.6.31-final.diff and one other manual fix.

    However when I connect to VPN it seems to work just fine, it holds for 1 minute and then stops responding. Connection drops within minutes with message:

    Secure VPN Connection terminated locally by the Client
    Reason: Remote peer is no longer responding.

    - I checked firewall of course, it’s disabled,
    - I checked group password, it is fine
    - I got 2 other PC’s on the same subnet using same pcf file, one EL linux with exact same VPN client version which works just fine, another PC with windows also works fine, so it shouldn’t be netowkr problem.
    - I traced IPSec, no errors, it just seems it never receives any packets from the concentrator

    Anyway, in the end I tried same connection with vpnc and it works just fine :) I should’ve started the other way around. Let that the be learning point.

    Lukas

  • gerhard says:

    looking for a solution for the unreadable menu and garbled window dressing on my thinkpad T42 I found this web site and Brads comments.
    Adding the items to xorg.conf made the thinkpad work als expected.
    Thank you, Brad

  • Tim says:

    Thanks, the recommendations on the xorg.conf file worked.

    However, I saw another post which actually turned on XAA instead and named the identified ATI 7500.

    I hadn’t tried that, wondering if that worked.

    I haven’t been able to get compiz however to work even after this tweak, but it solved some gobbledygook that was showing up.

  • Michi says:

    Works great… Many thanks!

    Have you had experience with Kubuntu 10.04 ‘Lucid Lynx’ and ‘Compaq EVO n610c’? I don’t dare to upgrade my Kubuntu version now…

    • Brad Hudson says:

      Hi Michi. I have since upgraded the laptop to 10.04 and have had no issues. I installed it fresh from a beta CD so I did not keep any of the changes I made in this blog. I’ve since dist-upgraded to the full Kubuntu and all is still working fine. I think you should be safe to upgrade.

Leave a Reply

  • (will not be published)

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>