MS Windows Vista Tips for Administrators

Posted in: Technical Track

I found myself, as a fresh member of The Pythian Group, losing precious moments just to change a few standard administrative settings on my new laptop with Microsoft Windows Vista. Having found the answers, I’m sharing them with you so that you can save some time, or spend it more pleasurably out in the summer.

User Account Control (UAC)

Too many prompts and confirmations for admin tasks? Set “Elevate without prompting” for “User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode” under Start -> Settings -> Control Panel -> Administrative Tools -> Local Security Policy -> Security Settings -> Local Policies -> Security Options. Ref: UAC on Wikipedia.

Windows Vista Features

By default, telnet is not installed with Windows Vista. To (re-)enable it, select the Telnet Client check box in Start -> Settings -> Control Panel -> Programs and Features -> “Turn Windows features on or off”. Then, Windows Features dialog -> Telnet Client. Now you may use telnet from the command prompt as you are used to in XP. Ref: FAQ on


Adjust for best performance (this applies to XP too). Select the radio button next to “Adjust for best performance” in Start -> Settings -> Control Panel -> Performance Information and Tools -> Advanced Tools -> Adjust the appearance and performance of Windows -> Visual Effects.

Mounting: Do not mount a local share on the same system

I’m used to creating a secondary disk partition to store all user data, but this time I forgot to do that before I filled up almost whole disk. As a workaround, I created a new folder named DATA, shared it locally, and mounted it as network drive.

At first, I was quite happy as it would save me time on data movements when a space issue occurred on one of the partitions. Later, though, I started to observe strange behaviour — freezing of the whole system, while working with data on the mounted drive (especially while doing parallel actions like file copying, installations, etc.). A few days later I gave up debugging frozen processes, and unmounted and removed the share; everything works fine now. Have you experienced anything similar?

If you know these already, I apologize, and add that if know more Vista tips, please put them in the comments below. But definitely stay tuned, more tips coming!

Have a nice one, Jan Polnicky.

Interested in working with Jan? Schedule a tech call.

About the Author

No comments

Leave a Reply

Your email address will not be published. Required fields are marked *